Troubleshooting
Workflow Deployment Error
If there were any errors during the workflow deployment process, the Ingestion Pipeline Entity will still be created, but no workflow will be present in the Ingestion container.
- You can then Edit the Ingestion Pipeline and Deploy it again.
- From the Connection tab, you can also Edit the Service if needed.
Connector Debug Troubleshooting
This section provides instructions to help resolve common issues encountered during connector setup and metadata ingestion in OpenMetadata. Below are some of the most frequently observed troubleshooting scenarios.
How to Enable Debug Logging for Any Ingestion
To enable debug logging for any ingestion workflow in OpenMetadata:
Navigate to Services Go to Settings > Services > Service Type (e.g., Database) in the OpenMetadata UI.
Select a Service Choose the specific service for which you want to enable debug logging.

Select a Service
- Access Ingestion Tab Go to the Ingestion tab and click the three-dot menu on the right-hand side of the ingestion type, and select Edit.

Access Agents Tab
- Enable Debug Logging In the configuration dialog, enable the Debug Log option and click Next.

Enable Debug Logging
- Schedule and Submit Configure the schedule if needed and click Submit to apply the changes.

Schedule and Submit
Permission Issues
If you encounter permission-related errors during connector setup or metadata ingestion, ensure that all the prerequisites and access configurations specified for each connector are properly implemented. Refer to the connector-specific documentation to verify the required permissions.
Troubleshooting: pg_stat_statements
Relation Does Not Exist
Issue
When running a query through OpenMetadata, you may encounter the following error:
Cause
This error occurs because the PostgreSQL extension pg_stat_statements
is not enabled. This extension is required to access query execution statistics, which are used by OpenMetadata for usage and performance insights.
Solution
Enable the pg_stat_statements
extension in your PostgreSQL instance. You can do this by executing the following command as a superuser:
Additionally, ensure the extension is loaded at server startup by setting the following in your postgresql.conf
:
After making this change, restart the PostgreSQL server.
For more details, refer to the official PostgreSQL documentation: pg_stat_statements – PostgreSQL
Learn how to resolve the most common problems people encounter in the PostgreSQL connector.
Column XYZ does not exist
If when running the metadata ingestion workflow you get a similar error to:
Then you might be using an unsupported postgres version. If we double-check the requirements for the postgres connector: Note that we only support officially supported PostgreSQL versions. You can check the version list here.
Error: no pg_hba.conf entry for host
When trying to connect to a PostgreSQL server hosted on Azure/AWS using basic authentication, the connection may fail with the following error message:
This error generally indicates that the host trying to access the PostgreSQL server is not permitted according to the server's pg_hba.conf
configuration, which manages authentication.
Whitelist the IP address
Ensure that the IP address provided by the OpenMetadata Service wizard is whitelisted in the Azure network firewall rules. You should also verify that the correct IP is added in the firewall for the database to allow connections from OpenMetadata.Check pg_hba.conf File
While Azure-managed PostgreSQL doesn't allow direct access to modify thepg_hba.conf
file, you can control access using Azure Firewall rules. Ensure that the IP address attempting to connect is allowed.Verify Network Access
Ensure that the PostgreSQL server is accessible from the internet for the allowed IP addresses. If the server is behind a VPN or private network, adjust the network settings accordingly.Adjust SSL Mode
The error could also be related to SSL settings. Setting the SSL mode toallow
can help resolve this issue. Modify the connection settings in the OpenMetadata Service configuration to:
This will allow the connection even if SSL is not enforced by the server.
Error: PAM authentication failed for user "<user>"
If you are facing this error, it means that the user you are using to connect to the database does not have the necessary IAM permissions.
In order to be able to connect via IAM, you need to have the following:
Database is configured to use IAM authentication Ensure that the RDS has IAM DB authentication enabled. Otherwise, you can click on Modify to enable it.
The user has the necessary IAM permissions Even if you use IAM to connect to postgres, you need to specify a user to prepare the connection. You need to create a user as follows:
- The AWS Role has the necessary permissions The role that is going to be used to perform the ingestion, needs to have the following permissions: